sexta-feira, 8 de janeiro de 2016

Configurando Estrutura de ramais Voip no Cisco 2811 Call Manager Express

Cisco 2811 Call Manager

Roteiro para Simulação e Testes no Packet Tracer.

  • Inserir os equipamentos.
  • Conectar os cabos adequadamente.
  • Criar as VLANs ( Dados, Voz e Gerenciamento ).
  • Criar sub interfaces no roteador.
  • Associar sub interfaces as VLANs.
  • Configurar o DHCP.
  • Configurar os serviços de telefonia.
  • Criar os DN e Ephones.
  • Registrar os telefones.
Componentes utilizados neste exemplo.
  • 1 Roteador de serviços integrados Cisco 2811.
  • 1 Switch Catalyst 2950-24.
  • 3 Telefones IP modelo 7960.
  • 3 Desktops.
Introduzindo os equipamentos e cabeando-os.

Layout Packet Tracer

Criando VLANs no Switch.

VLANs a serem criadas no switch S1: VLAN 10 = Dados, VLAN 20 = Voz, VLAN 99 = Gerenciamento, Atribuir o IP 192.168.99.10 a gerencia e Atribuir gateway padrão 192.168.99.1.

Comandos utilizados no Switch.
S1(config)#vlan 10
S1(config-vlan)#name Dados
S1(config-vlan)#vlan 20
S1(config-vlan)#name Voz
S1(config-vlan)#vlan 99
S1(config-vlan)#name Gerenciamento
S1(config-vlan)#exit.

S1(config)#interface vlan 99
S1(config-if)#ip addr 192.168.99.10 255.255.255.0
S1(config-if)#no shutdown
S1(config-if)#exit.

S1(config)#ip default-gateway 192.168.99.1.

Definindo porta trunk.
S1(config)#interface fa0/1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 99
S1(config-if)#no shutdown
S1(config-if)#.

Atribuindo VLAN as portas.
S1(config)#interface range fa0/2-4
S1(config-if-range)#switchport mode access
S1(config-if-range)#switchport access vlan 10
S1(config-if-range)#switchport voice vlan 20
S1(config-if-range)#exit 
S1(config)#

Atribuindo sub interfaces no Router.

Comandos para sub interfaces no Router.
R1(config)#int fa0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0
R1(config-subif)#exit.

R1(config)#int fa0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0
R1(config-subif)#exit.

R1(config)#int fa0/0.99
R1(config-subif)#encapsulation dot1Q 99 native
R1(config-subif)#ip address 192.168.99.1 255.255.255.0
R1(config-subif)#exit.

R1(config)#int fa0/0
R1(config-if)#no shutdown

Configurando o DHCP no Router.
R1(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.9
R1(config)#ip dhcp excluded-address 192.168.20.1 192.168.20.9

R1(config)#ip dhcp pool Dados
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#

R1(config)#ip dhcp pool Voz
R1(dhcp-config)#network 192.168.20.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.20.1
R1(dhcp-config)#option 150 ip 192.168.20.1 (Opção para voz)
R1(dhcp-config)#

Configurando o serviço Telefone.
R1(config)#telephony-service
R1(config-telephony)#max-dn 3 (máximo número de ramais)
R1(config-telephony)#max-ephones 3 (máximo número de telefones físicos)
R1(config-telephony)#auto assign 1 to 3 (atribuição automática de telefones)
R1(config-telephony)#ip source-address 192.168.20.1 port 2000
R1(config-telephony)#

Configurando os ramais dn (Direct Number).
R1(config)#ephone-dn 1
R1(config-ephone-dn)#number 101
R1(config-ephone-dn)#exit.

R1(config)#ephone-dn 2
R1(config-ephone-dn)#number 102
R1(config-ephone-dn)#exit.

R1(config)#ephone-dn 3
R1(config-ephone-dn)#number 103
R1(config-ephone-dn)#exit.

Registrando os ramais.
R1(config)#ephone 1
R1(config-ephone)#type 7960
R1(config-ephone)#mac-address (Colocar o MAC-ADDRESS do Dispositivo)
R1(config-ephone)#button 1:1
R1(config-ephone)#exit.

R1(config)#ephone 2
R1(config-ephone)#type 7960
R1(config-ephone)#mac-address (Colocar o MAC-ADDRESS do Dispositivo)
R1(config-ephone)#button 1:2
R1(config-ephone)#exit.

R1(config)#ephone 3
R1(config-ephone)#type 7960
R1(config-ephone)#mac-address (Colocar o MAC-ADDRESS do Dispositivo)
R1(config-ephone)#button 1:3
R1(config-ephone)#exit
R1(config)#

Verificando as configurações no Router.

R1#show ephone ephone-1 Mac:0001.4244.9CBC TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 12 and Server in ver 8 mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8 IP:192.168.20.10 1163 7960 keepalive 43 max_line 2 button 1: dn 1 number 101 CH1 IDLE ephone-2 Mac:00D0.58DA.5E70 TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 12 and Server in ver 8 mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8 IP:192.168.20.12 1190 7960 keepalive 43 max_line 2 button 1: dn 2 number 102 CH1 IDLE ephone-3 Mac:0030.F2AA.C429 TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 12 and Server in ver 8 mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8 IP:192.168.20.11 1198 7960 keepalive 43 max_line 2 button 1: dn 3 number 103 CH1 IDLE R1#

Agora basta entrar na interface gráfica do telefone IP e discar para outro ramal.

Telefone IP

Conteúdo Relacionado: Configurando Route Pattern no Cisco CUCM 9.x

Curtir Pagina no Facebook